Issue Impacting Billing Functionality
Incident Report for Sitey
Resolved
This issue has been resolved. We apologize for any inconvenience caused and hope you have a fantastic weekend!
Posted 3 months ago. Jun 28, 2019 - 22:02 EDT
Identified
The issue has been identified and we're working with a third party to work towards a resolution. We appreciate your patience and will provide additional updates as soon as possible.

Thank you!
Posted 3 months ago. Jun 28, 2019 - 20:01 EDT
Investigating
We are currently aware of an issue that is impacting billing functionality. Currently, you may experience issues updating your payment method or purchasing new services. Our engineering team is currently investigating the issue and we will provide an update ASAP.

Thank you for your patience.
Posted 3 months ago. Jun 28, 2019 - 19:17 EDT
This incident affected: Support and Billing.