Phone Support Temporary Unavailable
Incident Report for Sitey
Resolved
This incident has been resolved.
Posted about 2 months ago. Jul 25, 2019 - 21:03 EDT
Monitoring
We are currently able to take phone calls and are monitoring the fix to ensure proper resolution. We appreciate your patience during this outage and are happy to be back online to support you!
Posted about 2 months ago. Jul 25, 2019 - 20:08 EDT
Update
We are still working to fully resolve this issue. Our phone support is available again but you may have longer than normal hold times. We appreciate your patience while we work to resolve this issue.
Posted about 2 months ago. Jul 25, 2019 - 16:27 EDT
Update
We have identified the issue and are working towards a full resolution. We're currently able to take phone calls but may continue to experience degraded performance. We appreciate your patience while we work to resolve this issue!
Posted about 2 months ago. Jul 25, 2019 - 13:53 EDT
Identified
We are currently working on resolving an issue impacting access to our phone support team. We appreciate your patience while we work to resolve this issue. In the meantime, our chat support is available for your convenience. We will provide an update within the hour.

Thank you!
Posted about 2 months ago. Jul 25, 2019 - 13:51 EDT
This incident affected: Support.