Phone Support - Intermittent Downtime
Incident Report for Sitey
Resolved
This incident has been resolved.
Posted Sep 25, 2019 - 16:02 EDT
Monitoring
A fix has been implemented and calls are now routing to our support team! We appreciate your patience!
Posted Sep 25, 2019 - 13:05 EDT
Identified
We've identified an issue impacting our phone support team. When contacting the phone support team, you may experience longer than usual hold times. Additionally, you may experience silence when attempting to connect with an advisor. We are working with our engineering team to resolve as quickly as possible. We appreciate your patience! Thank you!
Posted Sep 25, 2019 - 12:29 EDT
This incident affected: Support.